Mail Client Configuration shows incorrect server name

Sometimes it happen the Mail Client Configuration(cPanel > Email Accounts > any email account in list > More > Configure Email Client) option generates incorrect server name under “Secure SSL/TLS Settings”

The server name can be corrected in the following files of cPanel.

/var/cpanel/ssl/dovecot-CN
/var/cpanel/ssl/exim-CN
/var/cpanel/ssl/courier-imapd-CN
/var/cpanel/ssl/courier-pop3d-CN

Slow downloading speed from server

This can be of many reasons, might be due to server load, firewall etc. Basically we check these areas when slow downloading speed occurs 🙂

But I have identified one uncommon and not easily notifiable thing on my server regarding with my public Ethernet interface. Please see the following result.

———————-
# ethtool eth0
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Half
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Supports Wake-on: g
Wake-on: g
Link detected: yes
———————-

Did you notice the Speed: 100Mb/s and Duplex: Half ?, that is the issue here 😀 which allows only half duplex transmission – transmission to only one direction at a time and thus limits the speed.

You can change to full duplex as follows:

————–
ethtool -s eth0 speed 100 duplex full autoneg off
————–

This will change the half duplex to full which allows sending and receiving at a time. Also set auto-negotiate to off as the switch has this function set to and it is best to match up the options.

(Note : In some server it can be eth1 the public interface and eth0 use for internal network, in that case change eth0 to eth1. Always be careful with that)

Then #service network restart

———————-
# ethtool eth0
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: Not reported
Advertised pause frame use: No
Advertised auto-negotiation: No
Speed: 100Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: off
MDI-X: Unknown
Supports Wake-on: g
Wake-on: g
Link detected: yes
———————-

Make sure secondary IPs associated with your ethernet are up, if not showing in ifconfig, then restart ipaliases.

#/etc/init.d/ipaliases restart

ERROR : Can’t locate Net/SNMP.pm in @INC

Recently I met with an error in server while checking traffic in and traffic out plugin for monitoring system(Nagios).

———–
Can’t locate Net/SNMP.pm in @INC (@INC contains: /usr/local/lib/perl5/5.8.8/i686-linux /usr/local/lib/perl5/5.8.8 /usr/local/lib/perl5/site_perl/5.8.8/i686-linux /usr/local/lib/perl5/site_perl/5.8.8 /usr/local/lib/perl5/site_perl .) at /usr/local/nagios/libexec/check_bw_snmp_out line 16.
BEGIN failed–compilation aborted at /usr/local/nagios/libexec/check_bw_snmp_out line 16.
———–

This can be easily fixed by installing Net::SNMP

Try,

#cpan
#cpan> install Net::SNMP