cPanel Internal PHP or 3rd party PHP is not working.

I came into an issue like I was not able to install softaculous in server since the 3rd party php in cPanel was broken. The cPanel version in server was 11.36. The following has had no output.

========
# /usr/local/cpanel/3rdparty/bin/php -v
#
========

Unfortunately there is not script “/scripts/makecpphp” available on cPanel latest verion 11.36, there is entirely a different method to correct internal php issue in new cPanel.

The issue here was the RPMs for PHP were broken, along with a few other applications, and had to be reinstalled. I did it in the following way.
========
# /scripts/check_cpanel_rpms
[20130509.121247]
[20130509.121247] Problems were detected with cPanel-provided files which are RPM
controlled.
[20130509.121247] If you did not make these changes intentionally, you can correct
them by running:
[20130509.121247]
[20130509.121247]> /usr/local/cpanel/scripts/check_cpanel_rpms –fix
[20130509.121247]
[20130509.121247] The following files were found to be altered from their original
RPM:
[20130509.121247] bandmin,1.6.1,9.cp1136
[20130509.121247] cpanel-cairo,1.8.10,1.cp1136
[20130509.121247] cpanel-fontconfig,2.8.0,1.cp1136
[20130509.121247] cpanel-freetype,2.4.10,1.cp1136
[20130509.121247] cpanel-perl-514-Cpanel-TaskQueue,0.307,3.cp1136
[20130509.121247] cpanel-php53,5.3.17,5.cp1136
[20130509.121247] cpanel-php53-SOAP,0.13.0,1.cp1136
[20130509.121247] cpanel-pixman,0.24.2,1.cp1136
[20130509.121247] cpanel-rrdtool,1.4.7,1.cp1136
[20130509.121247] cpanel-wwwcount,2.5,2.cp1136
[20130509.121247]
Do you want to repair these RPMs?(y/n): y

You should be good to go at this time.
========

The issue has been resolved.

========
# /usr/local/cpanel/3rdparty/bin/php -v
PHP 5.3.17 (cli) (built: Apr 12 2013 10:47:19)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
with the ionCube PHP Loader v4.2.2, Copyright (c) 2002-2012, by ionCube Ltd.
========

Leave a Reply

Your email address will not be published. Required fields are marked *